[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error with guix pull

From: Gary Johnson
Subject: Re: Error with guix pull
Date: Sat, 16 Dec 2017 15:50:12 -0500
User-agent: mu4e 0.9.18; emacs 25.3.1

I tried running "guix pull" again after I got your message, but I
actually got a different error that time. (Unfortunately, I didn't take
the time to save it.) Anyway, I ran "guix pull" again today, and this
time it worked, so I guess the problem has been resolved.


Ludovic Courtès <address@hidden> writes:

> Hi Gary,
> Gary Johnson <address@hidden> skribis:
>> I tried running "guix pull" today, and at the end of the compilation
>> phase, I was presented with this error:
>> --8<-------------------------------------------------------------->8--------
>> copying and compiling to 
>> '/gnu/store/29nci1d7zykwriwhnpxqivilbi6cr8wc-guix-latest' with Guile 2.2.3...
>> loading...       26.1% of 656 filesrandom seed for tests: 1513007529
>> compiling...    100.0% of 656 files
>> Backtrace:
>> Exception thrown while printing backtrace:
>> In procedure public-lookup: Module named (system repl debug) does not exist
>> --8<-------------------------------------------------------------->8--------
> This is a bug that apparently manifests itself randomly when building
> with Guile 2.2.3, as was the case here.  (I suspect it has to do with
> thread-safety in the presence of autoloaded modules.)
> We’ve switched back to using 2.2.2 in ‘guix pull’ to address
> <>.  Can you try running ‘guix pull’ again?
> Thanks in advance,
> Ludo’.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]