[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Instantiating the OS declaration after a small change

From: Arnaud B
Subject: Re: Instantiating the OS declaration after a small change
Date: Fri, 6 Apr 2018 15:03:05 +0200

Hello Ludo

Thanks for helping me.
Actually I had come up with that declaration :
  (file-systems (cons* (file-system
                        (device "my-root")
                        (title 'label)
                        (mount-point "/")
                        (type "ext4"))
                        (device "backup3")
                        (title 'label)    ;; ntfs uuid requires conversion
                        (mount-point "/home/arnaud/backup3")
                        (needed-for-boot? #f)
                        (mount? #t)  
                        (flags '())   ;; options such as ro come here
                        (type "ntfs-3g"))

but reading the sources in guix/file-systems.scm, I see that is not an option in fact. But I see that besides ext and btrfs there is now support for luks encrypted partitions in the way, and that is great news for my other disks.

So, for the ntfs one, I guess I'll have to manually mount / unmount it as you explained. Actually, after installing the ntfs-3g package, it worked with this :
sudo ntfs-3g -o uid=1000 -o gid=998 /dev/sdb1 /home/arnaud/backup3/
The uid / gid bits were necessary to get read-write access ; it worked flawlessly in console but not in Gnome's file manager for some reason, but that didn't bother me as I rely on emacs dired  instead.

As for the GUI, yes I'm using Gnome at the moment but I intend to go back to my usual stumpwm, as I have not managed to have guile-wm running (but on paper that would be awesome - without the capital of course !)



2018-04-06 10:26 GMT+02:00 Ludovic Courtès <address@hidden>:

Arnaud B <address@hidden> skribis:

> Context :
> In the process of trying to build packages, through the use of guix
> environments, I need more space on my home partition.
> To do so, deleting former generations followed by 'guix gc' was not enough,
> and I need to move things to my external ntfs drive (please don't ask why I
> have to use that file system...).
> As I'm regularly going to mount it, I added a file-system declaration in my
> config.scm.


> Question :
> Do I have to apply 'guix system reconfigure', a lenghty process (on my
> computer at least) for such a small change, especially if I did not write
> it correctly, or is there another possibility ?  I actually just want to
> test that file system declaration.
> From 6.2.13 of the manual, I'm thinking about 'guix system build'. Or could
> I do it temporarily in another scm file ?

I have a similar use case: an external HDD that I plug in from time to

What I do is declare it as not being automatically mounted on startup:

       (title 'uuid)
       (device (uuid "eeeeeeee-eeee-eeee-eeee-eeeeeeeeeeee"))
       (mount-point "/mnt/disk")
       (type "ext3")
       (mount? #f))

This adds an entry to /etc/fstab so when I plug it in, I can simply time
“sudo mount /mnt/disk”.

Now, if you use GNOME or similar, the udisks service and its friends are
support to automatically mount partitions from removable storage.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]