[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix on Android works, guix pull fails on guile-ssh build in the che

From: Chris Marusich
Subject: Re: Guix on Android works, guix pull fails on guile-ssh build in the check phase
Date: Sat, 12 May 2018 19:49:02 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)

白い熊@相撲道 <address@hidden> writes:

> On May 9, 2018 9:10:07 PM UTC, "白い熊@相撲道" <address@hidden> wrote:
>>Currently, it runs as regular user — however I can't guix pull, as it
>>fails in the check phase in guile-ssh build — as seen in the attached

If those failures occur on the latest version of guile-ssh, it might be
helpful to open a bug report upstream:

> I'm still trying to overcome this—it seems to me, this should be, but
> don't know how to accomplish it:
> — Build a local version of guile-ssh passing configure flags to it to
> skip tests;
> — “Freeze” it, so it wouldn't be rebuilt during guix pull; 
> — Then I should be able to update guix; 
> [...]
> This is getting even more confusing: 
> guix build guile-ssh builds it without any error, doesn't fail—yet
> guix pull keeps failing in the same spot. How can this be remedied?

How did you invoke "guix pull"?  Based on your suggested plan of attack,
it sounds like you modified the Guix source locally (on your Android
system), recompiled it, and then tried to use "guix pull" from that
newly built version.  Something like that.  Is that right?

If you don't tell "guix pull" where to get the Guix source from, it gets
the latest version from the Git repository hosted on Savannah.  If it
does that, then it will use the package definitions from that version,
which means it won't use any of the local changes you made.  I think
what you need to do, if you want to disable the guile-ssh tests, is
something more like this:

  guix pull --url=file:///path/to/your/custom/guix/repo

You might also need to use the --commit or --branch options, as
described in the manual (see: "(guix) Invoking guix pull").  You might
not need to specify the "file://" prefix in the URL; I can't remember.

If you invoke "guix pull" in this way, you are telling it to use the
version specified by what you have *committed* in your custom Guix repo.
Make sure you commit the change that disables guile-ssh tests, or it
won't be included when "guix pull" fetches from the repo.

If you do "guix pull" in this way, it should build the custom version of
guile-ssh that you made which disables the tests.  I haven't tried this
myself, though, so no guarantees!  I hope it helps.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]