[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GuixSD installation issues (missing commands and build errors)

From: Julien Lepiller
Subject: Re: GuixSD installation issues (missing commands and build errors)
Date: Thu, 12 Jul 2018 10:07:38 +0200
User-agent: K-9 Mail for Android

This looks like the kind of error that occurrs when your RAM is corrupted. You 
should run a memtest I think.

Le 12 juillet 2018 00:48:41 GMT+02:00, address@hidden a écrit :
>I've encountered a problem with installing GuixSD 0.15 (from the latest
>ISO image
>burnt to a DVD). I followed the manual as well as I could.
>The first, no-so-important issue is that I get an error message about
>some tools not beeing found by bash. These include mkfs.ext4, mkfs.fat,
>parted, cfdisk. These are the only ones I really used and noticed it
>on. This doesn't always happen. Whenever I reboot from the DVD again,
>the commands on which I get the error change. Sometimes for example
>mkfs.ext4 doesn't work, something else might work, you reboot and
>something else might break while mkfs.ext4 might work again, it seems
>completely random. You can workaround this by executing these tools
>directly from their directory (they are present!) such as going to
>e2fsprogs directory and manually executing mkfs.ext4.
>However, the real problem for is this:
>First of all, I partitioned and mounted as follows:/dev/sda1 is the ESP
>(I use EFI), mounted to /mnt/boot/efi/dev/sda2 is the main FS, label is
>"my-root" like in the manual, ext4, mounted to /mnt/dev/sda3 is swap
>I use the desktop.scm template as config.scm, minus the part for mapped
>devices and I replaced "my-root" with (file-system-label "my-root")
>because guix system init told me to do so., rest is left default.
>On the first run of "guix system init /mnt/etc/config.scm /mnt" I get a
>huge error message, its too big to even see all of it (lists many many
>packages though). The end says that the "builder for
>/gnu/store/*-profile.drv failed with exit code 1"  and  that it "cannot
>build derivation "/gnu/store/*-system.drv: 1 dependencies couldn't be
>built". I am unsure which dependency could not be built.
>When I run "guix system init /mnt/etc/config.scm /mnt" a second time I
>get 5 package collision warnings (for wayland-egl.pc, giomodule.cache,
>, mimeinfo.cache, ifconfig), but it does get to the
>copying to /mnt stage.
>I then, at some point in the copying to /mnt stage, get the following
>"guix system: error: lstat: No such file or directory: " followed by a
>package directory
>I've tried this several times and the packages I got the errors on so
>far were:guile-ssh 2 or 3 timesfuse 2 or 3 timesguile 1 time
>It seems random on which of these packages I get the error.
>I can't make any sense of these problems, and if further information is
>needed I will of course provide it. Does anyone have an idea?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]