[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: installing guixsd on an arm device

From: Mark H Weaver
Subject: Re: installing guixsd on an arm device
Date: Mon, 20 Aug 2018 13:59:08 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Hi Julien,

Julien Lepiller <address@hidden> writes:

> I'm trying to install GuixSD on a cubietruck. For that, I installed a
> foreign distro, installed guix using the binary method, pulled to the
> latest version and I eventually ran "guix system init /etc/config.scm 
> /".
> After that, I rebooted and I can use the HDMI cable to see what's
> happening. The uboot screen appears and boots my kernel alright. The
> issue I have is that, a few seconds after the kernel is booted, it
> freezes. I tried to use a usb keyboard, but it wasn't recognised (it
> didn't light up and nothing appeared on the screen). Here is a photo of
> what is on the screen when it is frozen:
> [732 KB]
> and here is the config file I tried to use:
> I don't see any error message. I've tried letting the server powered on
> for a few hours, and nothing happened.

It might be worth trying an older kernel, specifically linux-libre-4.14,
by adding (kernel linux-libre-4.14) to the OS config and making sure to
import (gnu packages linux).  I just recently updated the kernel to
4.18.x, but I don't know if anyone has tried it on ARM yet.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]