[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GuixSD system reconfigure error

From: Hebi Li
Subject: Re: GuixSD system reconfigure error
Date: Thu, 30 Aug 2018 14:51:21 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Hi Ricardo,

Thanks, I believe this is the reason. Today when I run several rounds of
build, the `kernel module not found "shpchp"` error pops out here and
there (it isn't there yesterday ..)

I used initrd-modules and "shpchp", because back when I first installed
the system, the example configure file had them. I don't think I really
need the modules. So I tried removing it, but system seems to prevent me
from doing that, by throwing the error:

   <unknown location>: error: you may need these modules in the initrd
   for /dev/sda2: shpchp

It seems weired to me, in two ways:

1. why the system is preventing me from removing "shpchp" module? How
does it relate to /dev/sda2 (which is my root partition in ext4)?

2. I downloaded the latest QEMU image [1], run as root the `guix pull`
and `guix system reconfigure` with the exact config.scm (with modified
boot loader configure of course), and there isn't any issue. I believe
that build should also use the latest kernel, which should also have
missed the module "shpchp".

Next, I would probably try to reinstall the system, without the
`initrd-modules` configuration.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]