[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help to workaround #28144

From: Fredrik Salomonsson
Subject: Re: Help to workaround #28144
Date: Tue, 29 Jan 2019 00:01:14 -0800

Ricardo Wurmus <address@hidden> writes:

> Fredrik Salomonsson <address@hidden> writes:
>> Hello guix,
>> I'm hitting the issue described in
>> This happens when I do "guix pull", "guix package -u" or "guix
>> environment guix".
>> guix --version
>> guix (GNU Guix) 0.16.0-8.7ba2b27
>> The comments mention deleting "guix/profiles.go" should work as a work
>> around. But I'm not sure which one that is. Is there a more detail
>> explination somewhere that I can follow?
> This would only help if you were using Guix from a git checkout.  If you
> don’t do that, your only way around this is to use an older version of
> Guix to run “guix pull”, e.g. ~/.config/guix/current-1-link/bin/guix.
> -- 
> Ricardo

Ah got it.

I didn't have ~/.config/guix/current-1-link/bin/guix, so I ran
/var/guix/profiles/system-1-link/profile/bin/guix pull. That solved the
issue and I can now run "guix pull" and "guix environment guix"
again. Haven't tried "guix package -u" but I would assume that works as

Thanks for the help!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]