[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 'CONFIG_HEADER not defined' during sed compile during 'guix pull'

From: Nathan Valentine
Subject: Re: 'CONFIG_HEADER not defined' during sed compile during 'guix pull'
Date: Wed, 30 Jan 2019 23:44:10 +0000

Thanks for looking at things, Ricardo.

> That’s not good but I cannot reproduce this as of Guix
> ba123b6dda3afb84c457f9e68c20eeff61e2c740. I ran “guix build --check
> sed” to build sed. (Are you running the daemon on a system where
> SELinux is enabled?)

I get no output and a 0 exit code when I run the --check but some information 
about the VM I'm using is below. I started out with SELINUX enabled but have 
since disabled it in the VM thinking that perhaps that was a source of problems:

$ dnf copr list ;  rpm -qa | grep guix ; selinuxenabled; echo "selinuxenabled: 
selinuxenabled: 0

The first few lines of the guix pull command output are:

Updating channel 'guix' from Git repository at 
Building from this channel:
  guix   24886c1
substitute: guix substitute: warning: ACL for archive imports seems to be 
uninitialized, substitutes may be unavailable
building /gnu/store/x96jqkjd7jagszan8srmqblhgx1g6qmc-sed-4.5.drv...

> I also wonder why you’re building things from source when you can get
> binaries from the build farm instead. Did you forget to authorize the
> build farm public key or are you purposefully building everything from
> source?

The docs mention Substitutions being disabled for binary installations...

Substitutes from the official build farm are enabled by default when using the 
Guix System Distribution (see GNU Distribution). However, they are disabled by 
default when using Guix on a foreign distribution, unless you have explicitly 
enabled them via one of the recommended installation steps (see Installation). 
The following paragraphs describe how to enable or disable substitutes for the 
official build farm; the same procedure can also be used to enable substitutes 
for any other substitute server.

I (incorrectly) assumed that was because on a Binary Installation the Guix 
install must rely on some local packages during pull. I'll enable substitutions 
and report the outcome.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]