[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] 504 gateway timeout (was Re: guix package builds, subsitute

From: Giovanni Biscuolo
Subject: 504 gateway timeout (was Re: guix package builds, subsitutes and --no-build)
Date: Thu, 21 Feb 2019 16:14:46 +0100


thanks for helping!

I'm also involving guix-devel since probably this issue must escalate

I think my specific problem is caused by the "Gateway Timeout" error
from, see below for details

Leo Famulari <address@hidden> writes:


> Did you authorize substitutes for

not explicitly but my (user) guix accepts it by default, I was able to
install other packages with no problem, also tried again some minutes
ago and succeeded installing gnumeric

this also means that my problem installing ungoogled-chromium substitute
does not depend from my X.509 problem shown below (subsitutes are
installed via and I'm able to install them)

still, if I try to install ungoogled-chromium on my machine, it starts

--8<---------------cut here---------------start------------->8---
$ guix package -i ungoogled-chromium
substitute: updating substitutes from ''... 100.0%
| 'unpack' phase
--8<---------------cut here---------------end--------------->8---

now, guix weather tell me this:

--8<---------------cut here---------------start------------->8---
$ guix weather --manifest=.ungoogled-chromium.manifest
computing 1 package derivations for x86_64-linux...
looking for 1 store items on
  100.0% substitutes available (1 out of 1)
  99,3 MiB of nars (compressed)
  288,3 MiB on disk (uncompressed)
  0,004 seconds per request (0,0 seconds in total)
  262,4 requests per second
  '' returned 504 ("Gateway Time-out")
--8<---------------cut here---------------end--------------->8---

actually all returns 504 "Gateway Time-out":
AFAIU this mean I'm not able to install that package (possibly others)
for some problem in the CDN

>> guix/build/download.scm:313:6: In procedure tls-wrap:
>> X.509 certificate of '' could not be verified:
>>   signer-not-found
>>   invalid
>> --8<---------------cut here---------------end--------------->8---
> Also, did you set up X.509 certificates for use by Guix?

ouch no :-S (I'm on foreign distro)

I've installed nss-certs (and configured my env) and now "guix weather"
does not report the above error

>> and checking the build logs it's clear my problem is lack of space in /tmp
> Yes, I don't know off the top of my head how much space it needs but
> since the source alone is several gigabytes I recommend 15 GB.

wow: I don't have so much space in /tmp so I have to find an alternative
:-) (i.e. grow my volume, LVM unfortunately [1])

>> please how can I set a different TMPDIR for the build process?
> You need to set this variable in the context of the guix-daemon:

the builder! guix-daemon is The Builder!

thanks Leo: I read that once in the manual but missed it yesterday when
I needed it :-S

in my case (I'm on Debian with systemd) I have to add an "Environment="
parameter in /etc/systemd/system/guix-daemon.service, reload the systemd
file and restart the service


[1] because LVM is still not fully supported by Guix

Giovanni Biscuolo

Xelera IT Infrastructures

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]