[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUIX installation / uninstallation problem

From: Zelphir Kaltstahl
Subject: Re: GUIX installation / uninstallation problem
Date: Wed, 17 Apr 2019 21:44:11 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1

I already fixed it : )

I had to _restart_ the guix daemon. Note: It was already running
according to `systemctl status`. So this might be worth some
consideration for the future: If the daemon is running, but there is no
socket, tell the user something like: "You might need to restart your
guix daemon."

It would be great to have an official uninstallation / removal guide for
Guix, that does prevent all problems in future reinstalls of Guix.

Now I only need to fix the issue with the locales again. That is a topic
for another question under a different title though.


> Message: 2
> Date: Wed, 17 Apr 2019 13:48:35 +0200
> From: Hans-Werner Roitzsch <address@hidden>
> To: address@hidden
> Subject: GUIX installation / uninstallation problem
> Message-ID: <address@hidden>
> Content-Type: text/plain; charset=utf-8
> Hello Guix users!
> I sort of messed up my Guix setup as follows:
> I installed Guix using the binary installer script. The installer asked
> me, whether I wanted to allow prebuilt packages and I thought: "Nah, let
> it compile packages." Not considering how long that would take initially
> and/or with any updates for packages.
> Then I started installing the locales as suggested, when you do not have
> them yet, which I think is always the case on a fresh Guix installation.
> So I started installing those with the command provided by the Guix
> installer.
> I think it spent already 30min or so compiling stuff, when I canceled
> it. Then I started looking for a way to change the prebuilt thingy
> setting, as I realized what I had done. I found no way to change the
> setting and neither did any web search yield anything helpful. So I went
> ahead and thought "Isn't it like a thing contained in one directory? I
> should be able to simply delete Guix using `rm -rf` ?". I deleted `/gnu`
> and a few other locations.
> Then I tried to install Guix again, but it refused to "overwrite" an
> existing installation. So there must have been traces of the previous
> installation left somewhere. I searched more about uninstalling Guix and
> found very little. At some point I found the following Arch Linux wiki
> link:
> I removed all the guixbuilders and the group guixbuild. Then I removed
> the other paths mentioned in the wiki article.
> Finally Guix installer did not find any previous installation any longer
> and installed, seemingly without problems.
> But then I started to see the actual problem. When I tried installing
> the locales following the installation of Guix an error with the guix
> daemon socket came up:
> =====
> guix package -i glibc-utf8-locales
> guile: warning: failed to install locale
> hint: Consider installing the `glibc-utf8-locales' or `glibc-locales'
> package and defining `GUIX_LOCPATH', along these lines:
> ??? guix package -i glibc-utf8-locales
> ??? export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale"
> See the "Application Setup" section in the manual, for more info.
> guix package: error: failed to connect to
> `/var/guix/daemon-socket/socket': No such file or directory
> =====
> So now my question is: How can I repair my Guix, its socket, or better
> yet: Completely remove and reinstall it?
> Thanks for any help!
> Hans

reply via email to

[Prev in Thread] Current Thread [Next in Thread]