[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix on a foreign distro (Mint) - List of packages is outdated and n

From: Julien Lepiller
Subject: Re: Guix on a foreign distro (Mint) - List of packages is outdated and not updatable
Date: Tue, 23 Apr 2019 09:36:30 +0200
User-agent: K-9 Mail for Android

Le 23 avril 2019 22:02:00 GMT+02:00, MutoShack <address@hidden> a écrit :
>I've been using Guix for a while on my Mint 19.1 machine. When Nano 4.0
>came out as a Guix package I was excited, so I ran:
>'guix pull && guix package -u'
>on my machine. It pulled Nano 2.9.3 from (I
>recently had Nano 3.4 installed, which means Guix downgraded my
>My laptop computer, running GuixSD, pulled Nano 4.0 (and other new
>packages) perfectly fine.
>'/path/to/guix-daemon --substitute-urls="";'
>and pulling yields the same result.
>Deleting '~/.config' on both user & root, then letting 'guix pull'
>regenerate them also did nothing.
>I tried changing my generation and deleting old generations.
>I tried the good old "RTFM" and "STFW" methods (reading info and
>websearching), but I could not find an answer. Maybe I misunderstood
>information I found.

Hi, this sounds like you're not using she right guix, like a guix installed in 
your profile. If that's the case, every time you "upgrade", you actually 
downgrade guix itself and the packages it knoos about.

Make sure that ~/.config/guix/current/bin tomes first in your $PATH and run 
"hash guix" to make sure your shell refers to the right guix.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]