[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GuixSD on a laptop with Heads

From: Jonathan Frederickson
Subject: GuixSD on a laptop with Heads
Date: Tue, 30 Apr 2019 23:01:51 -0400
User-agent: Cyrus-JMAP/3.1.6-449-gfb3fc5a-fmstable-20190430v1

Hey - so I'm trying to get GuixSD running on a Thinkpad X230 running Heads.

( For some background: this system boots

into a Linux environment, has scripts that parse the GRUB config, and boots

into the final system using kexec.

The Heads boot scripts do not currently support booting from a system with

full disk encryption, so I'm attempting to boot manually to start (after which

I can patch the scripts to replicate what I did). However, I'm running into

some issues when attempting to boot into the new kernel - the moment I run

kexec, I get no output onscreen from the new kernel:

I've tried adding the usual debug flags to the kernel command line for

troubleshooting (debug, higher LOGLEVEL, earlyprintk to vga) with no change.

I'm not too familiar with the Linux boot process beyond GRUB configuration and

the like, and I'm running out of ideas... does anyone have any pointers on

things I could try next?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]