[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: IceCat from Guix all monospaced font

From: Zelphir Kaltstahl
Subject: Re: IceCat from Guix all monospaced font
Date: Sat, 4 May 2019 22:00:37 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1

Hi, thanks for your reply!

First I tried the fc-match. It returned:

DejaVuSans.ttf: "DejaVu Sans" "Book"

Then I looked for the ~/.config/gtk-3.0/settings.ini file. It did not
exist, only "bookmarks" and "gtk.css" existed at that location. So I
created the "settings.ini" file and put in there the following:

gtk-font-name=i"DejaVu Sans" "Book" 11

After that another fc-match with same result:

DejaVuSans.ttf: "DejaVu Sans" "Book"

Still no luck in Icecat. I restarted it, but still everything in its UI
and on all websites is monospaced, despite other settings in
"userChrome.css" in my browser profile (for UI) and Icecat preferences
(for websites).



On 5/4/19 9:25 PM, ison wrote:
> Icecat is a GTK3 application. Have you tried setting your GTK3 font?
> You can do so with an application like lxappearance
> (under the "widget" tab, select "Default font")
> Alternatively you can set it manually.
> If I'm not mistaken it should be in the file: ~/.config/gtk-3.0/settings.ini
> At the bare minimum I think you should have this:
> [Settings]
> gtk-font-name=<My Font> <Weight> <Size>
> The weight can be things like "Regular", "Medium", or "Bold" or other variants
> Make sure your font is being located correctly by fontconfig. You can test it
> with: fc-match "My Font"
> Also, for the record you might want to check what gets returned when you just
> type fc-match with no options. Because that's usually the default most
> applications will select, and it sounds like you might have it set to a
> monospace font, which probably isn't the best setting in general.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]