[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Guix VM can't connect to the Internet

From: Philip K.
Subject: Guix VM can't connect to the Internet
Date: Sun, 05 May 2019 18:19:43 +0200

Hi, in light of the 1.0.0 release, I tried to download the Guix VM
image, to try and configure a workable setup within a Qemu session
before installing it.

But `guix package pull` wouldn't work, because no connection could be
established. Running `ping` on any server, would just inform me of
dropped packets, `ip link set eth0 up` wouldn't change anything.

I tried altering the quemu flags:

        qemu-system-x86_64 -net user -net nic,model=virtio -enable-kvm \
    -m 2048 guix-system-vm-image-1.0.0.x86_64-linux

adding and removing net flags, enabling and disabling kvm. Since I am
not a Qemu expert, let alone a VM guy, I have really no idea what the
-net options for example do.

Could someone give me a hint what I should try/read to get a working

        With kind regards,
        Philip K.

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]