[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cannot set max open files (ulimit)

From: Arne Babenhauserheide
Subject: cannot set max open files (ulimit)
Date: Sat, 11 May 2019 00:34:28 +0200
User-agent: mu4e 1.2.0; emacs 26.1

Hello Guix Hackers,

I am struggling to change the nofiles limit. When I try to build, I
regularly run into "too many open files" errors, and ulimit gives me 

$ ulimit -Hn
$ ulimit -Sn

To increase that I tried to add the following:

 (services (cons* 
            (pam-limits-entry "*" 'hard 'nofile 'unlimited)
            (pam-limits-entry "*" 'soft 'nofile 'unlimited)))
          (service sysctl-service-type
                    (settings '(("fs.file-max" . "500000")))))
                  (modify-services %desktop-services
                                   (ntp-service-type config =>
                                                      (servers (list 

But after restarting I still get the same ulimits.

I need to get this fixed, since I hope that it’s the last thing which
prevents me from setting up a fully functioning homeoffice environment.

What am I doing wrong?

Best wishes,
Unpolitisch sein
heißt politisch sein
ohne es zu merken

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]