[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Input method change in GNU IceCat installed via Guix

From: znavko
Subject: Re: Input method change in GNU IceCat installed via Guix
Date: Sun, 12 May 2019 12:50:56 +0000

Have you added the keyboard layout switcher applet to the Xfce4-panel ? screen:
Does it change layout in Icecat with mouse click on it?

May 12, 2019 11:33 AM, "Zelphir Kaltstahl" <address@hidden 
(mailto:address@hidden<address@hidden>)> wrote:

        I am running Xfce4 and the display server is: 

        $ ps -e | grep tty7 1319 tty7 00:14:38 Xorg 

        What does "system config" entail? 


On 5/12/19 12:41 PM, address@hidden (mailto:address@hidden) wrote:  

        Hello, Zelphir! I had such problem on Gnome+Wayland. It did not used 
another newly added layout, but only US even when I choose Russian in the 
applet in the gnome toolbar (the bar on top). It was for all apps under 
Gnome+Wayland. But I only tried to config system for it, so I had not purpose 
to solve it. I have no such problem in Xfce4. What is your desktop environment 
and display server? Also your system config might be needed. May 12, 2019 10:10 
AM, "Zelphir Kaltstahl" <address@hidden> (mailto:address@hidden) wrote: 

        Hi Guix Users! Recently I installed GNU IceCat via Guix. A few days ago 
I noticed something: I cannot switch input method when the GNU IceCat window is 
focused. My shortcut was CTRL+tilde before and I already tried changing it to 
the more common CTRL+ALT+space, but that also does not work. To me it seems, 
that IceCat does not bubble up the keyboard event for this shortcut to the 
system and then the system (Xubuntu 18.04) does not notice, that I pressed the 
input method switching shortcut. But that is only a guess, as I do not really 
know how the order of keyboard event processing is organized. If it was only 
switching a few characters on the keyboard, I could live with simply typing 
differently, but when I want to input Chinese characters, I currently need to 
open another program, any text editor not having this issue, and then type 
there and copy paste it into IceCat. I am using Fcitx for input method 
management. My GNU IceCat version is `60.3.0esr (64-bit)`. Another application 
where it does not work is Emacs. However, there the useful built-in IM exists 
which can be switched to by: `C-u C-<backslash> chinese-py <return>` so I do 
not need it there. What can I do to make IM switching work when IceCat is 
focused? Regards, Zelphir

reply via email to

[Prev in Thread] Current Thread [Next in Thread]