[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot install Guix 1.0.1 on Asus K50C

From: znavko
Subject: Re: Cannot install Guix 1.0.1 on Asus K50C
Date: Sun, 16 Jun 2019 10:29:44 +0000

Thank you! The installation was finished ok. But 'reboot' after system 
initialization (as manual says) did not worked ever on my Asus K50C.

I've used in config the name of device as /dev/sda everywhere, and Guix runs 
ok. Think, manual should have notices about it for those not want to use label 
of device. 
Also if I do not use separate partition for bios grub, guix says that it is not 
allowed (but on my other laptop i have only one partition for root and grub).
Also the size of grub partition was 200Mb first, and somebody said I need only 
1Mb, but I've seen my other notebook's /boot directory has files about 20Mb, so 
I've create boot partition with 80Mb space. And I see this now:

# du -h /boot
2.3M    /boot/grub/fonts
4.2M    /boot/grub/locale
2.4M    /boot/grub/i386-pc
8.9M    /boot/grub
8.9M    /boot

The next trouble connects to my VGA Display Adapter Sis 771/671 and its driver. 
I've solved this on ubuntu, and now I will push another email for get my screen 
works normal resolution on Guix.

June 16, 2019 8:40 AM, "pelzflorian (Florian Pelz)" <address@hidden> wrote:

> On Sun, Jun 16, 2019 at 08:17:56AM +0000, address@hidden wrote:
>> Hi, Florian! I have reinit system with config like this:
>> (initrd-modules (append (list "sata_sis")
>> %base-initrd-modules))
>> where underscore is placed instead of dash: sata_sis.
> Yes.
>> I did not understand where should I type --skip-checks, sorry.
> Maybe you do not need it. If it fails without --skip-checks, it is
> `guix system reconfigure --skip-checks /path/to/your/config.scm`.
> Please try without --skip-checks first. It may be a bug if this is
> necessary.
>> I use BIOS Grub, so I created a separate partition of type BIOS boot and 
>> size 76Mb. Am I right of
>> its size?
> I believe it is sufficient, although you do not need to use a separate
> /boot partition.
>> Also, may be I need to update by usb flash, cause there is Guix 1.0.1 of age 
>> 3 weeks. Might be the
>> new image has some bugfixes for me?
> I do not know if there were changes to kernel modules.
>> Please, should I type /dev/sda everywhere in config.scm instead of /dev/sdb? 
>> When I boot to usb my
>> ssd disk is showing like /dev/sdb, but when I boot from ssd disk it is 
>> /dev/sda, so this config
>> does not work. And this ubiquitous option was not described in manual. I 
>> always read:
>> "For legacy systems, the target field names a device, like /dev/sda;... "
>> So, what to do?
> Please use UUIDs to name the devices, as described in the manual.
> Regards,
> Florian

reply via email to

[Prev in Thread] Current Thread [Next in Thread]