[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: docker-compose not work

From: Tobias Geerinckx-Rice
Subject: Re: docker-compose not work
Date: Mon, 17 Jun 2019 03:27:30 +0200


Edison Ibáñez wrote:
I have tried to update the package as you can see in the paste

but I still have the same error.

Well, I had already said as much in my previous e-mail:

Tobias Geerinckx-Rice wrote:
However, even 1.24.0 complains about jsonschema<3,>=2.5.1 not being found. Since Docker insists on using an old library, and I don't feel comfortable removing the version constraints (I don't use Docker),

So please guix pull, update docker-compose (‘guix upgrade docker-compose’), and check whether it works with the old version of python-jsonschema I added.

Even if you want to update to 1.24.0, you'll still have to add python-jsonschema-2.6 as an input, as done in commit 914bba28096c1b85e368537c02e9841258887acb.

Lastly, I'm aware that updating to a 1.24.0 that builds is trivial (I had to do so to write the above), but I don't know if it will actually work in practice without updating the rest of Docker. Hence the conservatism.

Kind regards,


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]