[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Computer suspends even when I tell it not to

From: Chris Marusich
Subject: Re: Computer suspends even when I tell it not to
Date: Wed, 19 Jun 2019 22:44:42 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Hi Mark, Pierre, and others,

Thank you for taking the time to offer suggestions.

Pierre Neidhardt <address@hidden> writes:

> Maybe unrelated, but I've noticed that when I log out it goes to sleep
> too (only sometimes?).
> When it wakes up, it shows the GDM clock, which I can slide to log in
> again.
> I use GDM and EXWM.

This is pretty much the same as the behavior I see.  At first I thought
the machine was going to sleep a long time after I logged out, but the
other day I definitely observed it immediately go to sleep when I logged
out, which seems wrong.

I also recall a little notification showing up briefly at the top of the
screen, at the GDM login screen, saying something along the lines of
"The computer will suspend soon if you take no further action".

Mark H Weaver <address@hidden> writes:

> FWIW, I've never seen this on my Thinkpad X200 running Guix.  I also use
> GNOME, although I use it under Wayland, by running
>   XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session
> from within a text console.  I don't use GDM, because our GDM package
> does not yet support Wayland.
> Note that GDM is enabled in my OS config and gets launched on every
> boot, but I then shut it down manually using "herd stop xorg-server".
> After doing so, I need to type "Alt+SysRq+r" to recover the use of my
> keyboard.
>> Does anyone else experience this?  What else can I try?
> It might be worth trying to do what I describe above, to rule out the
> possibility that GDM is responsible.

I tried this, but I couldn't lock the screen.  Anecdotally, I feel like
the issue has happened when I lock the screen, and also when I log out,
but after a little poking around in this wayland session I wasn't able
to reproduce the issue, so I tried something else.

Instead of running the session, I simply stopped xorg-server and
recovered the use of my keyboard like you suggested.  The issue did NOT
occur, even though I left my computer unattended overnight.  I guess
that means it's a GNOME or GDM issue, but it's still unclear.

> What kind of machine is it?  If it's a laptop, I wonder if your laptop's
> embedded controller is entering suspend mode automatically.

I do NOT experience this issue on my x200 laptop.  I DO experience this
issue on a desktop.  They're using roughly the same software - both are
using GNOME, not using wayland, and I've run "guix pull" fairly recently
on both of them.  So it might be something hardware specific, but if so
it's strange that Pierre also sees the same issue.

I'll dig into the logs of my desktop and see if there is anything
helpful from around the time of the suspend.  I guess I'll poke around
at how we're running GDM, too.  Still not many clues to go on.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]