[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Screen doesn't lock on lid close in XFCE

From: Jonathan Frederickson
Subject: Screen doesn't lock on lid close in XFCE
Date: Sun, 7 Jul 2019 18:49:04 -0400

I recently tried switching from Gnome to XFCE on my X230. Almost
everything still works as expected, but I haven't been able to get the
screen locker to activate when closing the lid. If I suspend my laptop
using the sleep hotkey (Fn-F4), xlock is active when I resume the
laptop. However, if I suspend by closing the lid, no screen locker has
started when I resume.

I do have "Lock screen when system is going for sleep" checked in
Settings -> Power Manager -> System. My current system config can be
found here:

I tried searching the list archives to see if anyone else has
encountered this, but didn't find anything. I don't see anything
that looks relevant in /var/log/messages, though I could be missing
something. Has anyone seen this before/know the fix?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]