[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GuixSD doesn't boot on UEFI

From: Jack Hill
Subject: Re: GuixSD doesn't boot on UEFI
Date: Fri, 26 Jul 2019 16:18:42 -0400 (EDT)
User-agent: Alpine 2.20 (DEB 67 2015-01-07)

On Fri, 26 Jul 2019, address@hidden wrote:

I it freezes my UEFI so it doesn't boot... No GRUB, no GNU Shepard, nothing...


Wow, when it fails that early in the process, there is not that much to go on. Have you tried booting other other (non-Guix) media. It would be interesting to know if other live media (e.g. ) works for you.

How are you loading Guix unto your boot media? It might be interesting to try a CD or USB if you've only tried one so far.

This might be getting ahead of ourselves, but even if you can't get the Guix installer to boot, you may still be able to get Guix installed on your computer. Options are to connect the disk to a different computer and use Guix (potentially installed on a foreign distro) there to do the installation on the disk, and move it to the target computer once installed. I had to do this recently for a host that would not boot from external media. A variation on this theme would be to install use the Guix binary distribution on different live media that you are able to boot.

Also, if you hava way to do it, updating to the latest version of your UEFI code might be a good idea.

What computer and UEFI are you using?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]