[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues with Haskell's ghc

From: Ricardo Wurmus
Subject: Re: Issues with Haskell's ghc
Date: Sun, 04 Aug 2019 14:35:14 +0200
User-agent: mu4e 1.2.0; emacs 26.2

Prateem Mandal <address@hidden> writes:

>> I've run aground with Haskell's ghc (interpreter works fine) - running
>> ghc on a basic hello world program fails.  I identified couple issues:
>>  - Include directory for linux headers wasn't passed to gcc
>>    (`C_INCLUDE_PATH=/gnu/... ghc` fixed it)
>>  - Lib C's crti.o and crt1.o where not found during linking
>>    (fixed with `LIBRARY_PATH=/gnu/... ghc`)
>>  - libgmp and libffi aren't passed to linker's -rpath
>> If anybody uses Haskell here, i'd appreciate any insights on what might
>> be the root cause here.
> I am facing the same issue. I could resolve the second issue including
> glibc in the ad-hoc list while creating the environment (and I never
> hit the first issue). However I am now stuck with the third issue. In
> the original thread there was no resolution to this issue. Any idea
> how this can be fixed?

Installing the “gcc-toolchain” package should be sufficient.  Have you
tried that?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]