[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

man pages are empty and have a (command exited with status 255) error wh

From: Kenan Toker
Subject: man pages are empty and have a (command exited with status 255) error when quitting
Date: Sat, 14 Sep 2019 23:07:47 +1000

Hi All,

I have been having trouble getting man pages to work on a fresh
installation of Guix on a laptop. After I have installed man-db and
man-pages, if I run e.g. `man ls`, I get an empty man page with the
following at the footer of the page:

    Manual page ls(1) line ?/? (END) (press h for help or q to quit)

I am able to use the h key to look for help with man. When I press q to
quit, I get a message like the following:

    man: command exited with status 255: (cd
    /run/current-system/profile/share/man &&
    /gnu/store/[...]-man-db-2.8.5/libexec/man-db/zsoelim) | [...]

(I am currently getting starting to get myself familiar with the system
- which means I don't know how to copy-paste yet! If the rest of this
message is useful, I can pull it out and put it in a reply email.)

Has anyone had similar issues to this? I've tried installing and
uninstalling man-db and this hasn't done anything. I was running Guix in
a VM for a couple of months and never had any issues with man in that

Thanks a lot for any advice in advance.


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]