[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help Installing GuixSD on ThinkPad X60 tablet

From: Maxim Cournoyer
Subject: Re: Help Installing GuixSD on ThinkPad X60 tablet
Date: Fri, 20 Sep 2019 17:52:03 +0900
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)

Hello Byron,

BYRON ELIAS MOLINA HERMOSILLA <address@hidden> writes:

> Hi!
> I'm having a problem I hope someone can help me with :( I just got a
> refurbished ThinkPad X60 Tablet with 3GB RAM and a 128 SSD, and I was
> reading about the free distros that are available so I could later
> install libreboot and saw there was Guix, and I found it great! But
> the thing is, it wouldn't work :(
> I downloaded the i686 iso and flashed it to a 3.0 USB Kingston
> DataTraveler with Balena Etcher, it worked fine, it booted, I followed
> the graphical install, set the language and keymap, location, and
> chose to use full disk with separate home partition and full
> encryption, I also selected i3 and openbox as desktops and lastly
> mozilla https and tor network.
> It installed without errors, and asked me to reboot, after that it
> asked me the / encryption passphrase, got to the grub screen, then
> asked me the home passphrase, aaand... it booted to Gnu Guile! And by
> typing ",help guix" it only showed me the option to switch to bournish
> language! I read every single command that ",help all" showed me but
> none helped, I saw also something about "repl" in the welcome message
> but tried it and the command didn't work either.
> Then I thought maybe it was something about the greeter not being
> installed so I reinstalled with Gnome and i3 but same thing, booted to
> Guile, and I don't know how to boot the os itself.
> If anyone knows what I did wrong or had a similar situation, I would
> gladly appreciate it, I really wanted to try out Guix :( If you need
> any more information, I can provide. Thanks in advance!
> Byron ElĂ­as Molina Hermosilla,
> Software Engineering Student,
> INACAP Renca, Chile.

Without seeing your system configuration file, I can't say much; perhaps
something was messed up in the way you configured your file systems.  I
can only suggest you start from something which is *simple* and known to
be working, such as a lightweight desktop configuration.  There are
examples in the user manual providing working base systems (see the
section "8.1 Using the Configuration System").



reply via email to

[Prev in Thread] Current Thread [Next in Thread]