[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Guix Pull SSL Cert Invalid Old PC

From: nightowl
Subject: Guix Pull SSL Cert Invalid Old PC
Date: Sun, 22 Sep 2019 22:12:10 -0500
User-agent: Posteo Webmail

I have installed guix sd on an old ibm 32bit laptop (PentiumII), but after booting up into the new system, I have trouble running guix pull command to update the system store. It complains that the SSL certificate is invalid.

Because of limitations with the 32 bit machine, I had to install the system by removing the hard drive and connecting it externally to another modern laptop using a usb to ide adapter. I ran the guix system init to install the system onto the hard drive, then placed it back into the 32 bit laptop. Things boot and run ok using the slim login and the i3wm window manager, but cannot run the pull command without getting an invalid certificate error.

The interesting thing is, if I take the hard drive back out and boot off of it using one of my newer computers (I tried this on two of my newer computers), I can run the guix pull command and it works fine, the certificate registers ok in this case.

Why would the old computer say the certificate is invalid while two of my newer computers say it is ok?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]