[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

build issues w/ system glibc

From: Michael Zucchi
Subject: build issues w/ system glibc
Date: Thu, 19 Dec 2019 10:20:18 +1030
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0


Just a couple of comments re: building from git.  Well that was the intention, but it's turned into a failure to build.

1) bootstrap isn't mentioned anywhere in the README, it just mentions configure 2) i know the README is for a web service to reformat, but it's really miserable trying to read it from a shell
3) using "guix environment guix" the build fails.

$ make V=1
g++ -Wall -std=c++11 -g -O2   -o guix-daemon nix/nix-daemon/guix_daemon-nix-daemon.o nix/nix-daemon/guix_daemon-guix-daemon.o libstore.a libutil.a libformat.a -lz -L/gnu/store/i6l1579g80387rda658jy9cfqq82643d-sqlite-3.28.0/lib -lsqlite3 -L/usr/lib64 -lgcrypt -lbz2 /usr/bin/ld: /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ undefined reference to `__libc_vfork@GLIBC_PRIVATE'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:3469: guix-daemon] Error 1
make[2]: Leaving directory '/home/notzed/src/guix'
make[1]: *** [Makefile:4766: all-recursive] Error 1
make[1]: Leaving directory '/home/notzed/src/guix'
make: *** [Makefile:3257: all] Error 2

I'm using guix on Slackware-current and that (currently) uses glibc-2.30, and when using the platform compiler it links against that and not the guix glibc.

I tried installing gcc-toolchain but the same thing happens.  I tried -L/gnu/store/<path to glibc> but that doesn't work.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]