[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build issues w/ system glibc

From: Julien Lepiller
Subject: Re: build issues w/ system glibc
Date: Thu, 19 Dec 2019 09:03:42 +0100
User-agent: K-9 Mail for Android

Le 19 décembre 2019 00:50:18 GMT+01:00, Michael Zucchi <address@hidden> a écrit 
>Just a couple of comments re: building from git.  Well that was the 
>intention, but it's turned into a failure to build.
>1) bootstrap isn't mentioned anywhere in the README, it just mentions 
>2) i know the README is for a web service to reformat, but it's really 
>miserable trying to read it from a shell
>3) using "guix environment guix" the build fails.
>$ make V=1
>g++ -Wall -std=c++11 -g -O2   -o guix-daemon 
>nix/nix-daemon/guix_daemon-guix-daemon.o libstore.a libutil.a 
>libformat.a -lz 
>-lsqlite3 -L/usr/lib64 -lgcrypt -lbz2
>undefined reference to `__libc_vfork@GLIBC_PRIVATE'
>collect2: error: ld returned 1 exit status
>make[2]: *** [Makefile:3469: guix-daemon] Error 1
>make[2]: Leaving directory '/home/notzed/src/guix'
>make[1]: *** [Makefile:4766: all-recursive] Error 1
>make[1]: Leaving directory '/home/notzed/src/guix'
>make: *** [Makefile:3257: all] Error 2
>I'm using guix on Slackware-current and that (currently) uses 
>glibc-2.30, and when using the platform compiler it links against that 
>and not the guix glibc.
>I tried installing gcc-toolchain but the same thing happens.  I tried 
>-L/gnu/store/<path to glibc> but that doesn't work.
>  Z

Hi, have you tried runinhg everything in a pure environment, from the 
bootstrap? Guix environment guix --pure should give you an environment where 
none of your system is visible.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]