[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gpg-agent error: No pinentry

From: Marco van Hulten
Subject: Re: gpg-agent error: No pinentry
Date: Thu, 19 Dec 2019 09:22:58 +0100

Je 18 dec 22:50 skribis Andreas:
> On Wed, Dec 18, 2019 at 10:41:27PM +0100, Marco van Hulten wrote:
> > Do I need to do any more actions accept for 'guix package -i gnupg
> > pinentry'?  
> I also have a file .gnupg/gpg-agent.conf in my home directory
> containing the following lines:
> default-cache-ttl 300
> max-cache-ttl 3600
> pinentry-program /home/USERNAME/.guix-profile/bin/pinentry-curses

Thank you, Andreas and Gábor, very useful to know that pinentry-program
should be set.  I did so:

$ file $(realpath $(grep ^pinentry-program ~/.gnupg/gpg-agent.conf | awk 
'{print $2}'))
ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked,
for GNU/Linux 2.6.32, not stripped

Importing a public and private key pair, following [1], worked properly
now, but it still complains when decrypting a file.


To be sure, if I now try to remove the key, 'gpg --delete-key publiko',
it says that I need to use option "--delete-secret-keys" to delete the
private key first.  So it appears to be really there.  However,

    $ date | gpg -e > jadaja.gpg
    gpg: encrypted with 4096-bit RSA key, ID 54AE7D44B93BDBDF, created 
          "Marco van Hulten (publiko) <address@hidden>"
    gpg: public key decryption failed: No pinentry
    gpg: decryption failed: No secret key

I tried killing gpg-agent to be sure it uses the current configuration,
but again it complains about pinentry.

Apropos, I this e-mail is signed with this very key.


Attachment: pgpbcBvckZtQm.pgp
Description: OpenPGP digitale handtekening

reply via email to

[Prev in Thread] Current Thread [Next in Thread]