[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gpg-agent error: No pinentry

From: Marco van Hulten
Subject: Re: gpg-agent error: No pinentry
Date: Fri, 20 Dec 2019 22:15:14 +0100


Thank you for the help: the issue might have been solved, at least
sometimes (sort-of explanation follows)!

Je 20 dec 20:12 skribis Gábor:
> If you still have the patience to experiment a little could you try
> with pinentry-tty on the console and pinentry-gtk on a gui?

Yes, I just had a little bit of time before the new year.  (Christmas is
a holiday, they say!)

> It might be a valuable experience, and a feedback that our simple
> pinentry is faulty in some ways.
> I have extracted the inforamtions from my config, and it looks like this:
> manifest: (specifications->manifest '("gnupg" "pinentry-tty"))
> I also use guix home-manager [...]

A guix home-manager sounds intriguing.  I alluded to it once when
asking why we wouldn't define the state of the whole computing
environment.  But it adds a layer of complexity and so I don't think it
would be very useful to use this to analyse the problem I'm having.

> I am using bash, and I also have:
> At the end of my .bashrc:
> export GPG_TTY=$(tty)
> And at the end of my .bash_profile:
> gpg-agent --options /home/gabriel/.home-config/.gnupg/gpg-agent.conf --daemon
> I believe that is all.
> Could you have a look if it works for you with these settings? Also,
> please not that these are for console only use, most probably some
> other tweaks are needed to use this form a gui.

Yes, this helps!  That is, when I set GPG_TTY and started the gpg-agent
like this, 'gpg --import' and 'gpg -d' started to work without
complaining about pinentry.  But then I tried the same as another user
and there it still complained.  So I went back to the first user again,
removed the GPG_TTY variable and killed the gpg-agent, but now it does
not complain anymore about pinentry anymore at all.

I don't understand what's going on, but for now I'll just add the export
and gpg-agent commands in my .bashrc since that seemed to do the trick
at least once.

    export GPG_TTY=$(tty)
    gpg-agent --options ${HOME}/.gnupg/gpg-agent.conf --daemon


reply via email to

[Prev in Thread] Current Thread [Next in Thread]