[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ungoogled-chromium aborts on foreign distro via LTSP (Linux Terminal Ser

From: Giovanni Biscuolo
Subject: ungoogled-chromium aborts on foreign distro via LTSP (Linux Terminal Server Project)
Date: Fri, 10 Jan 2020 12:22:26 +0100

Hi Guix,

first and foremost kudos Marius Bakke for the great work in maintaining
this package!

if I run the last ungoogled-chromium Guix version in my terminal session
[1] on a Debian 10 server, I get SIGABRT:

--8<---------------cut here---------------start------------->8---
[14913:14913:0110/] No usable 
sandbox! Update your kernel or see 
 for more information on developing with the SUID sandbox. If you want to live 
dangerously and need an immediate workaround, you can try using --no-sandbox.
#0 0x561fb4b09f09 base::debug::CollectStackTrace()

Received signal 6
#0 0x561fb4b09f09 base::debug::CollectStackTrace()
  r8: 0000000000000000  r9: 00007ffc91ca6500 r10: 0000000000000008 r11: 
 r12: 00007ffc91ca7750 r13: 0000000000000170 r14: 00007ffc91ca7910 r15: 
  di: 0000000000000002  si: 00007ffc91ca6500  bp: 00007ffc91ca6740  bx: 
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007fee29c227fa  sp: 
  ip: 00007fee29c227fa efl: 0000000000000246 cgf: 002b000000000033 erf: 
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
--8<---------------cut here---------------end--------------->8---

If I run ungoogled-chromium with --no-sandbox it works, but I'd like not
to browse with the sandbox off (I'm going to study how to run my
browsers in a guix container, but it't not the solution AFAIU)

The same updated version of ungoogled-chromium from Guix on a Debian 10
laptop does not have this problem, so it's specific to the LTSP
environment I guess

The chromium binary from Debian 10 on the same LTSP environment does not
have the same problem, it works

Any suggestion on where to look for problems here, please?

Thanks! Gio'

[1] I have a couple LTSP terminals connected to a LTSP server

Giovanni Biscuolo

Xelera IT Infrastructures

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]