[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: XeLaTeX, fontspec, unsuccessful font search

From: Wiktor Żelazny
Subject: Re: XeLaTeX, fontspec, unsuccessful font search
Date: Thu, 23 Jan 2020 15:11:59 +0100

On Wed, Jan 22, 2020 at 04:25:43PM +0100, Wiktor Żelazny wrote:

> I’ve been tackling a similar problem as in [1]:
> $ cat minimal.tex

OK, I solved my pandoc problem by including `ghc-pandoc` along with
`texlive` among --ad-hoc inputs, rather than a regular one. From now on,
I will be using --ad-hoc, exclusively.

Still, this does not solve the issue with the fontspec example. I tried
the manual approach by following [1]. I dug through the symlinks just to
be sure.

$ guix environment … --ad-hoc texlive texlive-lm
[env]$ set | grep GUIX_ENVIRONMENT
[env]$ cd 
   lrwxrwxrwx 3 root root 127 Jan  1  1970 lmmono10-italic.otf -> 
[env]$ cd 
   lrwxrwxrwx 4 root root 122 Jan  1  1970 lmmono10-italic.otf -> 
[env]$ cd 
   -r--r--r-- 8 root root  63584 Jan  1  1970 lmmono10-italic.otf
[env]$ fc-cache 
[env]$ fc-cache -v 
 skipping, existing cache is valid: 72 fonts, 0 dirs
[env]$ ls | wc
        72      72    1653
[env]$ fc-list | grep Modern
   # nothing
[env]$ fc-list | grep lm
   # nothing

I also tried doing the fc-* stuff with sudo, nothing again.

There was no
, so I could not try the second approach mentioned in [1].



Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]