[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Repairs to USB drive prevents booting

From: Platoxia
Subject: Repairs to USB drive prevents booting
Date: Fri, 24 Jan 2020 23:04:20 +0000

I've had intermittent problems with a USB drive that finally resulted in my
having to boot up Trisquel to repair a bad superblock (magic number problem),
which resulted in a lot of blocks being moved around on that drive.

I don't know enough about how all the low level drive stuff works to properly
explain what is wrong but I assume Guix is looking for the bad superblock that
was moved/rebuilt during the repair...or something related.

The error I get when trying to boot up Guix:

e2fsck: no such file or directory while trying to open /dev/sdi1

file system check on /dev/sdi1 failed

By the way, the drive is connected and works fine with my Trisquel install after
the repair but will be scrapped in favor more internal drives (can't be 

This drive happens to be included in my guix configuration file's file system
declaration, which means it is automatically added to fstab and which can't be
manually edited since it is maintained by guix.

I have the data from the failing drive backed up and need to remove the failing
drive from my guix configuration file then reconfigure the system in order to
boot it up.

I've tried mounting the disk from my Trisquel install and manually changing
fstab...which is of course overwritten once the config files are loaded by
guix during boot.

I've tried mounting and chrooting to my guix install from a 1.0.1 installation 
to try to reconfigure the system with the drive removed from the configuration
file but I can't get it to work. I'm thinking it isn't possible but I don't know
enough to know for sure.

I've backed up the data from the failing drive and can wipe it if that will help
boot up guix but if it is looking for the superblock based on its previous 
on the drive it won't ever find it. All indication is that all the backup 
have changed location as well. I'm not sure exactly what e2fsck is looking for
and not finding at this point, TBH.

At any rate, I have backed up all data from my Guix install and have some new
hard drives on order and am planning on reinstalling the entire system into a
4+ drive raid 10 either with mdadm or btrfs, or maybe btrfs on top of an
md raid (still looking into it).

This is all on my home system and I'm just a tech hobbyist at best so any
advice on either how to get my current Guix installation to boot or on how
to best use (or not) raid 10 for a new install will be well received.

Best Regards,

Sent with [ProtonMail]( Secure Email.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]