[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Appropriate way to use Guix API from a Guile program

From: sirgazil
Subject: Appropriate way to use Guix API from a Guile program
Date: Wed, 20 May 2020 16:38:02 -0500
User-agent: Zoho Mail


I use Guix's GNU system. 

I had written a Guile script that called Guix procedures to manipulate 
profiles. I put it in a Guix package in a custom channel and installed it. It 
used to work, but now it fails with an error I can also reproduce when trying 
to do something similar from a Guile REPL. For instance:

$ mkdir profile-x
$ guile
GNU Guile 3.0.2
scheme@(guile-user)> (use-modules (guix scripts package))
scheme@(guile-user)> (guix-package "-m" "manifest.scm" "-p" 
error: glibc-bootstrap-system-2.2.5.patch: patch not found

This error is familiar. I got it in a slightly different context before when 
running the guix command directly from a terminal 

In the context of Guile scripting, how do I know which Guix is being imported? 

Also, I didn't include guix as an input in the Guix package of the script 
(though it worked). Thinking that it could make a difference, I tried adding 
guix as an input, pulled the new package definition, upgraded the package, ran 
the script, but got the same error.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]