[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: I tried Guix for half a day but had to go back to NixOS

From: zimoun
Subject: Re: I tried Guix for half a day but had to go back to NixOS
Date: Tue, 23 Jun 2020 19:03:15 +0200


On Wed, 24 Jun 2020 at 00:21, Yasuaki Kudo <> wrote:

> * Graphical installer run from a USB stick was broken.  I went insane, asking 
> the questions already answered and kept repeating them.   So I could not get 
> past the partition phase.
> * The Nouveau driver for my Nvidia graphics card detected a slightly off 
> resolution for my
> 4k monitor and at 30hz (not 60).   The installation of proprietary Nvidia 
> version seemed too daunting...
> * I struggled to find an installable web browser that had WebRTC (for online 
> conferences), which was IceCat.   I wonder if that's pretty much the only 
> choice for someone who needs precompiled code (because compiling a web 
> browser seems to take a long tome)
> Guix seems very interesting with Scheme and all but I had to go back to 
> NixOS.  😅

To mitigate the issue, instead of running full Guix System, you could
just run Guix as a package manager on the top of NixOS. :-)

Doing so, you can try Guix and what the Scheme offers without the issue
you described.  (I am running Guix on the top of Debian.)

Thank you for your feedback.

All the best,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]