[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: failing to package attrs-strict for swh.model

From: Marius Bakke
Subject: Re: failing to package attrs-strict for swh.model
Date: Wed, 24 Jun 2020 22:10:22 +0200

zimoun <> writes:

> Dear,
> I am trying to package "swh.model" which is a CLI tool developed by
> Software Heritage.  It allows to compute SWHID which is their internal
> hash tag.  This package is on PyPI, so I did:
>    guix import pypi -r swh.model
> which returns 2 packages: "python-attrs-srtict" and "swh.model".
> Aside some minor tweaks about the license, synopsis and description I
> added them to "gnu/packages/python-xyz.scm" and then I simply have tried
> to build:
>   ./pre-inst-env guix build python-attrs-strict
> Well, the first unexpected thing is an 404 error:
> --8<---------------cut here---------------start------------->8---
> building 
> /gnu/store/r6dgvrq486d8hdii9szz2filq85nbwjx-attrs-strict-0.1.0.tar.gz.drv...
> Starting download of 
> /gnu/store/9p0baqs1386gv5hhzrv5yrcj35klxpfi-attrs-strict-0.1.0.tar.gz
> download failed 
> "";
>  404 "Not Found"


> What do I miss?
> Then, from the PyPI webpage, I download the tarball by hand (wget) and
> then I run:
>     /pre-inst-env guix build python-attrs-strict \
>           --with-source=python-attrs-strict=attrs_strict-0.1.0.tar.gz

I notice the file name in this command is "attrs_strict".  Probably the
importer picked the wrong file name and you need to change it to
(pypi-uri "attrs_strict" version).

> which fails at the check phase.  Well, I have added as 'native-inputs'
> the packages "python-pytest" and "python-pluggy".  And I add these
> lines:
> --8<---------------cut here---------------start------------->8---
>     (arguments
>      `(#:phases (modify-phases %standard-phases
>                   (replace 'check
>                     (lambda _
>                       (invoke "pytest")
>                       #t)))))
> --8<---------------cut here---------------end--------------->8---
> But the tests is still failing with the same message at this end:
> --8<---------------cut here---------------start------------->8---
> AttributeError: type object 'Callable' has no attribute '_abc_registry'
> --8<---------------cut here---------------end--------------->8---

Can you paste the full package definition?

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]