help-guix
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can I easily install GNU Emacs 27.1.50 via Guix?


From: Dr. Arne Babenhauserheide
Subject: Re: Can I easily install GNU Emacs 27.1.50 via Guix?
Date: Fri, 18 Dec 2020 11:44:06 +0100
User-agent: mu4e 1.4.13; emacs 27.1

Carlo Zancanaro <carlo@zancanaro.id.au> writes:
> One may argue that the system is functioning correctly, and this is an
> unfortunate consequence of the way that Guix works. I would still
> consider the faulty behaviour a bug - even if it is a result of
> intentional decisions made in Guix's design. Running evince (i.e.
> /usr/bin/evince) is failing because of an environment variable that
> Guix's wrapper sets for emacs. That environment variable is propagated
> to child processes (as environment variables are), and in this
> instance that causes the child process to misbehave. This is a bug
> caused by Guix's wrapping of emacs.

In practical terms: You would expect Guix to rename the environment
variable and also patch all guix-installed programs so that they use the
renamed variable without affecting any non-Guix-Program?

Best wishes,
Arne
-- 
Unpolitisch sein
hei├čt politisch sein
ohne es zu merken

Attachment: signature.asc
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]