[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: efi dual boot issue

From: znavko
Subject: Re: efi dual boot issue
Date: Sat, 16 Jan 2021 13:18:57 +0000

You can find some examples on github with 'guix config'.
I have EFI Dual boot configuration here

bootloader field lookslike this:

                  (bootloader (bootloader-configuration (bootloader 
(target "/boot/efi")                                                    
(menu-entries (list (menu-entry                                                 
                             (label "Ubuntu")                                   
                                     (linux "(hd2,gpt3)/boot/vmlinuz")          
               (initrd "(hd2,gpt3)/boot/initrd.img"))))))         

This bootloader configuration was made when I tried
to boot Ubuntu with grub command line.
I've found with grub's 'ls' command a linuz image 
and initrd file and booted successfully.
After that  I was sure such config will work.

I can't imagine troubles you will have with MS Windows.
May be easier it will be to use two different hard disks 
and to change their order in BIOS?

January 15, 2021 9:24 PM, "kevinbanjo" <> wrote:

> Hi everyone. I'm trying to install a dual boot with windows 10 btrfs root
> GuixSD and I have a catch 22 I can't figure out how to resolve:
> When I go to generate the system it says that grub-install didn't work (I
> can't remember exactly why and I was in console mode so I couldn't
> copy/paste the error but the gist of it was that it was because I booted in
> bios mode).
> I had to go into bios and disable my legacy boot and windows still boots
> but I can't boot the GuixSD USB ISO.
> It's an HP laptop and when I hit ESC during boot and select boot options it
> walks me thru the EFI boot files and I picked both the boot files and it
> just returns to the boot menu.
> I also tried hard resetting my laptop (unplugging it, pulling out the
> battery and holding the power button down for a while) plus booting windows
> into recovery mode and letting it try and fix the boot (which probably only
> did the windows one as that was the only one that showed up) and still
> nothing.
> How do I build an EFI boot if I can't boot GuixSD ISO as EFI?
> TIA,
> -Kevin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]