[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Another Raspberry Pi data point

From: Richard Huxton
Subject: Another Raspberry Pi data point
Date: Wed, 10 Feb 2021 21:06:06 +0000
User-agent: Roundcube Webmail/1.4.10

I saw Jonathan Marsden's post the other day, but wasn't subscribed then, so this will have to be another data point.

I also have a Raspberry Pi 4, and it's quite a capable little machine. I run Debian bullseye (still in testing) for the host O.S. and lxd to provide container services.

Guix seems to work well for applications on top of both debian and alpine containers as the "foreign" O.S. There are fewer pre-built substitutes for 64-bit arm than x86 of course, but that is to be expected. Likewise, build-time can be a bit long on a Raspberry Pi.

I had some success in using `guix system container` to test some simple service setups and see how it worked. Not as slick as lxd (of course) but you could see the potential.

I had no success with building a vm or disk image - a build would take hours and then fail trying to assemble the boot subsystem, seemingly having switched to x86 architecture. This was despite all my debugging attempts seeming to show that the guile scripts were aware this was a 64-bit arm architecture for most of their run.

My eventual aim was to try and create lxc/lxd containers via guix, but step 1 of that was to get a VM working. I shall have another attempt in a few weeks. Part of my problem may just be that I am unfamiliar with arm boot setups.

So - as of the start of 2021, on top of a foreign distro Guix works fine on a Raspberry Pi. If you are reading by the end of 2021 I suspect it will work in any of the scenarios described in the docs.

  Richard Huxton

reply via email to

[Prev in Thread] Current Thread [Next in Thread]