[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Starting Sway a Wayland window manager

From: Joshua Branson
Subject: Re: Starting Sway a Wayland window manager
Date: Mon, 29 Mar 2021 11:07:50 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu/linux)

Bone Baboon <> writes:

> Joshua Branson writes:
>> I also just realized that sway started for me when I changed
>> %base-services to %desktop-services.
> If I reconfigure the system with `%desktop-services`:
> ```
>  (services %desktop-services)
> ```
> When I run `sway` on virtual terminal 1 sway does not start and I get
> this output:
> ```
> localhost dbus-daemon[380]: [system] Rejected send message, 2 matched
> rules; type="method_call", sender=":1.24" (uid=1000 pid=26112
> comm="sway ") interface="org.freedesktop.login1.Session"
> member="SetType" error name="(unset)" requested_reply="0"
> destination="org.freedesktop.login1" (uid=0 pid=381
> comm="/gnu/store/jdk3r1gs4d36n3aj9fscsvwwc9prnrzp-elogin")
> [backend/backend.c:303] Failed to open any DRM device
> [sway/server.c:49] Unable to create backend
> ```
> When I run `sudo sway` it outputs "XDG_RUNTIME_DIR is not set in the
> environment. Aborting.".

hmmm,  maybe this will help.  Here's my current guix config:

Joshua Branson (joshuaBPMan in #guix)
Sent from Emacs and Gnus
  "You can have whatever you want, as long as you help
enough other people get what they want." - Zig Ziglar

reply via email to

[Prev in Thread] Current Thread [Next in Thread]