[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix pull error after install i686 1.2.0

From: Bone Baboon
Subject: Re: guix pull error after install i686 1.2.0
Date: Sat, 10 Apr 2021 16:12:11 -0400

Vincent Legoll writes:
> I remember having seen an (default checked) option
> to install certificates when choosing packages to install.

> I have the "nss-certs" package installed from /etc/config.scm
> This may be what you're missing.

I reinstalled Guix on the laptop.  During the graphical install I used
the default checked option for the certificates.  The only difference
with the install on this computer was that at the end when it prompts
for the install media to be removed and the reboot button used it went
to a blue screen and did not power off.  So I held the power button to
turn the computer off.

I was able to boot and sign in normally.  With a working Ethernet
connection `guix pull` gave the same error.  However `sudo guix system
reconfigure config.scm` worked fine and was able to download using the
internet connection.

`nss-certs` is in the system configuration file.

`locate certificates` shows that `etc/ssl/certs/ca-certificates.crt` is
in the store.

`ls /run/current-system/profile/etc/ssl/certs/ | wc --lines` outputs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]