[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix pull error after install i686 1.2.0

From: Leo Famulari
Subject: Re: guix pull error after install i686 1.2.0
Date: Sun, 11 Apr 2021 15:04:14 -0400

On Sat, Apr 10, 2021 at 09:54:18PM -0400, Bone Baboon wrote:
> I can reproduce this after two separate install using this install
> image: 

Okay. I have installed this ISO in a virtual machine, following the
instructions in the manual section Installing Guix in a VM.

> The output of `guix pull`:
> ```
> Updating channel 'guix' from Git repository at 
> ''...
> guix pull: error: Git error: the SSL certificate is invalid
> ```

I logged in as a regular user, ran `guix pull`, and it completed
successfully. I also tried as root, and that worked too.

> I am running `guix pull` from a Linux console virtual terminal.
> I am running `guix pull` as a regular user (not root).


> `which guix` outputs "/run/current-system/profile/bin/guix".


> The output of `guix describe`:
> ```
> guix describe: error: failed to determine origin
> hint: Perhaps this `guix' command was not obtained with `guix pull'? Its 
> version string is 1.2.0rc2-1.0d4b1af.
> ```

This isn't quite right.

It's expected that, before the first `guix pull`, the origin is not
known. The per-user view of Guix, with provenance tracking, is created
on the first `guix pull`.

However, the version string should be 1.2.0.  Something has gone wrong
on your system and caused you to "go back in time" to an earlier
release, the second release candidate of the 1.2.0 release.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]