[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

How to debug hanging "check" phase when building Kakoune

From: Dmitry Matveyev
Subject: How to debug hanging "check" phase when building Kakoune
Date: Sun, 18 Apr 2021 12:26:20 +0600
User-agent: mu4e 1.4.15; emacs 27.2


I use guix on Arch Linux, version

When I run

     guix build --check kakoune

everything builds correctly.

Now I change original `source` definition to fetch not from url but from
git repository. Original source and version:

    (version "2020.09.01")
       (method url-fetch)
       (uri (string-append "";
                           "releases/download/v" version "/"
                           "kakoune-" version ".tar.bz2"))
        (base32 "0x81rxy7bqnhd9374g5ypy4w4nxmm0vnqw6b52bf62jxdg2qj6l6"))))

And my modified kakoune package:

    (define-module (mykak)
      #:use-module (guix packages)
      #:use-module (guix git-download)
      #:use-module (gnu packages text-editors))
      (inherit kakoune)
      (version "2020.09.01")
         (method git-fetch)
         (uri (git-reference
               (url "";)
               (commit (string-append "v" version))))
         (file-name (git-file-name "mykak" version))

Now when I run to build this package, assuming it is named

    guix build --check -f kakoune.scm

it freezes with this output:

    phase `build' succeeded after 29.7 seconds
    starting phase `check'
    ln -sf kak.opt kak
    cd ../test && ./run

And the problem as I figured out with printf debugging is on this line:

Same result is when I manually download tarball from github, unpack and
use it to build the package:

    (define-module (mykak)
      #:use-module (guix packages)
      #:use-module (guix download)
      #:use-module (guix gexp)
      #:use-module (gnu packages text-editors))
      (inherit kakoune)
      (version "2020.09.01")
       (local-file "/tmp/kakoune-2020.09.01" #:recursive? #t)))

I have assumption that this is somehow connected with read-write
permissions because when I keep failed builds and later try to delete
them, it asks whether I really want to delete some read-only files.

I have no idea how exactly that `test/run` script works with all the
pipes and output redirection. And I have no idea how to check why this
build phase hangs. Any tips would be really helpful.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]