[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Any way to boot Guix with root partition elsewhere?

From: Vladilen Kozin
Subject: Any way to boot Guix with root partition elsewhere?
Date: Fri, 30 Apr 2021 20:19:39 +0100

Hello guix.

My machine only has USB 2 and rusty old spinners. USB is obviously
slow and guix with its store will quickly destroy any consumer grade
USB stick I insert there. Rusty spinners are so slow I wouldn't want
my worst enemy running their OS on them. So, I plugged PCIe card with
NVMe SSD drive. Problem is, this BIOS won't expose them as available
for booting.

However, one can boot off USB and then "redirect" OS boot to that PCIe
SSD. I've successfully employed just this strategy on FreeBSD, which
lets you specify a different partition for late stage booting (at this
point those NVMe drives have been detected by FreeBSD early stages).

So, I installed Guix on that NVMe and thought I'd be clever and put
grub-bootloader on the USB drive simply by specifying (target
"/dev/sdWHATEVER") in the `bootloader-configuration`. `guix system
init config.scm /mnt` went perfectly fine. Reboot and of course `grub`
can't find the drive by UUID. And `grub rescue` shows that only this
USB is available, sadly it only then occurred to me that `grub` isn't
Linux or Guix so I guess it has no idea how to find those PCIe NVMe

Is there a way out of this predicament? I can see two options.
(1) can some Linux distro/bootloader do the FreeBSD trick: start on
USB but then chain-boot Guix off that SSD? IIUC grub's chain-boot is
of no help here, cause it simply won't even see that drive;
(2) install and run Guix off USB but somehow ensure that "IO heavy"
bits are mounted from that SSD. There's gotta be some (file-systems
...) combined with the way I `guix system init config.scm /mnt` (or
rather what else I mount under /mnt where) that would achieve this?

In the above I'm going the `manual installation` route i.e. I've been
more or less following
Sadly the GUI based install haven't worked for me even once - I always
find myself staring at some Guile exception or other. Manual worked
every time, though.

Thank you
Best regards
Vlad Kozin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]