[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

scheme error message: better hint at file location?

From: Andy Tai
Subject: scheme error message: better hint at file location?
Date: Tue, 4 May 2021 17:38:36 -0700

This is a guix question, or a guile question.

I am working on a package definition.  I run into this error from guile:
The following derivation will be built:
building /gnu/store/mc4ssrfp1bsima42rylxmnj8h1vjrik9-opencv-3.4.14.drv...
In ice-9/eval.scm:
   217:50 19 (lp (#<procedure 7ffff2b31d20 at ice-9/eval.scm:282:?> ?))
   217:33 18 (lp (#<procedure 7ffff2f547c0 at ice-9/eval.scm:212:?> ?))
   214:21 17 (_ #f)
   217:50 16 (lp (#<procedure 7ffff2b31c40 at ice-9/eval.scm:282:?> ?))
  217:50  2 (lp (#<procedure 7ffff2f1f1b0 at ice-9/eval.scm:196:?> ?))
   217:33  1 (lp (#<procedure 7ffff2f1f180 at ice-9/eval.scm:196:12?>))
In unknown file:
           0 (string-append "-DCMAKE_LIBRARY_PATH=" #f)

ERROR: In procedure string-append:
In procedure string-append: Wrong type (expecting string): #f

Since I just worked on the scheme code, I know where the error came
from.   But no where is the error message pointing to the actual line
number and the scheme file name of the error.   This can be confusing
if I don't just remember the context, which is in a scheme file in

(Sorry I am new to scheme).    Is there better way to help to identify
the error location in this scenario?

Thanks for info on this.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]