[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cmake error

From: Roy Lemmon
Subject: Re: cmake error
Date: Thu, 13 May 2021 19:17:14 +0100
User-agent: K-9 Mail for Android

Hi Thiago,

Thanks very much for your help. At least you have confirmed my take on guix's 
cmake !

Perhaps someone else will come along with some insight. The cmake patch makers 
for instance ...

I'll keep trying with the log file ...


On 13 May 2021 19:09:58 BST, Thiago Jung Bauermann <> 
>Hello Roy,
>Em quinta-feira, 13 de maio de 2021, às 14:17:21 -03, Roy Lemmon escreveu:
>> Hi again,
>> Just to not that the original CMakeList.txt file for fastjet uses
>> ExternalProject_Add with the URL command. Perhaps no-one has used cmake
>> in Guix with that option before ...
>That's a good possibility. I tried your CMakeLists.txt example with cmake 
>installed via Guix and I saw the same error. With my host distro's cmake it 
>works fine.
>So it appears that file(DOWNLOAD) is broken in Guix's cmake. Perhaps no one 
>noticed because when building guix packages, dependencies are download in 
>advance rather than as part of the build.
>> Still no solution ...
>Sorry, I'm not of much help. I only have very limited experience with 
>I tried using the LOG option in this way:
>file(DOWNLOAD "";
>     "fastjet-3.3.3.tar.gz" TIMEOUT 60 LOG FILE_LOG)
>message(STATUS "file log = ${FILE_LOG}")
>But ${FILE_LOG} is empty. Not sure whether I'm using the option in the 
>wrong way, or file didn't log this problem.

Sent from my Android device with K-9 Mail. Please excuse my brevity.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]