[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build Mesa with a different toolchain version

From: Thiago Jung Bauermann
Subject: Re: Build Mesa with a different toolchain version
Date: Thu, 03 Jun 2021 02:14:52 -0300


Thank you for your response.

Em quarta-feira, 2 de junho de 2021, às 06:22:48 -03, Efraim Flashner escreveu:
> On Tue, Jun 01, 2021 at 09:46:56PM -0300, Thiago Jung Bauermann wrote:
> > Hello,
> > 
> > I'm having and issue with Mesa on i686-linux which I suspect is caused
> > by the version of GCC used to build it (i.e. 7.5.0).
> > 
> > To test my theory, I'm trying to build Mesa with a newer version of the
> > compiler. I tried a few different things, but none worked. I would be
> > grateful if someone could help me figure out how to do this:
> > 
> > Try #1:
> > 
> > $ guix build --system=i686-linux \
> > 
> >     --with-input=gcc-toolchain=gcc-toolchain@10.3.0 mesa
> I believe you have the wrong command here. What you want is
> $ guix build --system=i686-linux \
>       --with-c-toolchain=mesa=gcc-toolchain@10 mesa

Thanks, that worked! I read most of the Guix manual, but I had forgotten 
about the `--with-c-toolchain` option. Searching for it in the manual
also made me find the `package-with-c-toolchain` function, which does
the same thing from Scheme code.

Though there’s something weird about Mesa’s build process. Different 
libraries end up linked to different GCC versions. :-/

$ guix build --system=i686-linux --with-c-toolchain=mesa=gcc-toolchain@10 mesa
successfully built /gnu/store/59mczv3gwq3bnnw2jqcj8vqimihqi6c1-mesa-20.2.4.drv

$ ldd 
G gcc               => 
(0xf52e7000) => 

$ ldd 
/gnu/store/5w54z00fldvgdknn06xp66irqslhp6ff-mesa-20.2.4/lib/ G 
gcc                   => 

Also the 32-bit game I’m trying to run somehow gets linked to different
Mesa builds too: => 
(0xf71a9000) => 
(0xf66c5000) => 

The 27yz… build is the GCC 10.3.0 one, and 6k4wj… is the GCC 7.5.0 one.

Perhaps my time would be better spent trying to help get ‘core-updates’
in shape rather than trying to work around a 4 years old compiler bug¹.


¹ – the bug is
in armel, but I’m getting the exact same error message in Mesa, so I
suspect it also affects i686.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]