[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Corrupt/missing store items

From: Jack Hill
Subject: Re: Corrupt/missing store items
Date: Tue, 22 Jun 2021 09:45:51 -0400 (EDT)
User-agent: Alpine 2.21 (DEB 202 2017-01-01)

On Tue, 22 Jun 2021, Jack Hill wrote:

On Tue, 22 Jun 2021, Christopher Baines wrote:

Jack Hill <> writes:

Given what i know about the problem: substitute operations are failing
because gnutls is not available, I tried:

jackhill@kalessin ~$ guix build --substitute-urls= /gnu/store/zkhymfsbrv0s4y7l778g78k6y65nidxd-gnutls-3.6.16.drv
jackhill@kalessin ~$ ls -l /gnu/store/jlk67v3nddhv0z963wfvahk8fc8gqcz8-gnutls-3.6.16 ls: cannot access '/gnu/store/jlk67v3nddhv0z963wfvahk8fc8gqcz8-gnutls-3.6.16': No such file or directory

So Guix think's it's sucessfully built gnutls, but it's still not
present in the store. I've also tried copying the store items from
other hosts. No luck so far…

Does guix gc --verify=repair say anything?

It fails, becasue without gnutls my substitute servers can't be contacted. I also can't reconfigure with http:// substitute servers. Unfortunatley, gc doesn't accept a substitute-urls option.

Ok, I started the daemon by hand with http-only substitute servers, and --verify=repair appears to have solved my problem as far as I can tell so far.

Thanks to you and nckx!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]