[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Corrupt/missing store items

From: Ricardo Wurmus
Subject: Re: Corrupt/missing store items
Date: Tue, 22 Jun 2021 20:46:18 +0200
User-agent: mu4e 1.4.15; emacs 27.2

Jack Hill <> writes:

Given what i know about the problem: substitute operations are failing
because gnutls is not available, I tried:

jackhill@kalessin ~$ guix build --substitute-urls= /gnu/store/zkhymfsbrv0s4y7l778g78k6y65nidxd-gnutls-3.6.16.drv
jackhill@kalessin ~$ ls -l /gnu/store/jlk67v3nddhv0z963wfvahk8fc8gqcz8-gnutls-3.6.16 ls: cannot access '/gnu/store/jlk67v3nddhv0z963wfvahk8fc8gqcz8-gnutls-3.6.16': No such file or directory

What happens if you try “guix build --check --no-grafts /gnu/store/zkhymfsbrv0s4y7l778g78k6y65nidxd-gnutls-3.6.16.drv” or similar? The database probably states that /gnu/store/jlk67v3nddhv0z963wfvahk8fc8gqcz8-gnutls-3.6.16 has already been built, so with “--check” you might be able to make it build it again.

So Guix think's it's sucessfully built gnutls, but it's still not present in the store. I've also tried copying the store items from
other hosts. No luck so far…

How did that fail?

How could the directory have disappeared? Guix appears to be very surprised that the directory is missing.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]