[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Broken Guix Pull

From: Christopher Howard
Subject: Re: Broken Guix Pull
Date: Fri, 02 Jul 2021 14:56:45 -0800

Hi, that's me!

I picked a random /gnu/store/*/bin/guix, and got the same error
message. I also, as I mentioned, did a separate checkout from guix and
built it myself, and running the guix pull from that. I could do try a
few more /gnu/store/*/bin/guix binaries to be thorough, but I expect I
would continue to get the same result.

Something is certainly corrupted somewhere, but I can't figure out
where, or what it is exactly that I need to repair or delete or

>From that repair command error message I posted, you would think it
would have to be that one guix package in the store. But then, why
doesn't it work with other guix binaries?

>From the build log I posted, it seems like guix is trying to load guix
code from some dependency package, but it definitely isn't clear to me
how that works.

-----Original Message-----
From: Tobias Geerinckx-Rice <>
To: Maxim Cournoyer <>
Cc: Christopher Howard <>,
Subject: Re: Broken Guix Pull
Date: Sat, 03 Jul 2021 00:16:25 +0200

Maxim Cournoyer 写道:
> I hope others will have more helpful replies than mine, but 
> perhaps your
> file system was badly damaged.

If this is lispmacs from #guix, that's exactly what happened after 
a power failure.

I don't see it mentioned in the OP but I also suggested running 
‘guix pull’ from each /gnu/store/*/bin/guix, but apparently that 
didn't work(?).

Kind regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]