[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix on a cloud VM

From: Ben Sturmfels
Subject: Re: Guix on a cloud VM
Date: Thu, 02 Sep 2021 10:26:37 +1000
User-agent: mu4e 1.6.5; emacs 27.2

Thanks Mathieu! We've discussed further on IRC, but summarising below
for the list.

On Tue, 31 Aug 2021, Mathieu Othacehe wrote:

> Oh, too bad. You could maybe contact Binary Lane support to find out
> why? Have you tried to boot your qcow2 image on your machine with QEMU?
> The command line would look like the one presented here:
>> I've also tried efi-raw which boots and runs smoothly, but fails to
>> resize later on my hosting service. (Resize is required because
>> otherwise I literally have to generate and upload a 20GB image.) I
>> suspect (but don't know for sure) that this is related to the additional
>> 40M EFI partition created in the image before the root EXT4 partition.
>> The images provided by my hosting service only have a single EXT4
>> partition eg. Debian 10.
>> Do you know if it's possible to get `guix system image` to skip the EFI
>> partition when creating an efi-raw image?
> No it is not possible currently, due to how Grub is installed on Guix
> System images. However, you should be able to resize your partition
> manually using fdisk and resize2fs, see below :).

I contacted Binary Lane's support and they advised that while they
didn't support QCOW2, I could resolve the resizing issue by using their
"BYO OS" configuration, rather than their built-in image configurations
like "Debian". Doing so disables their auto-magic storage resizing
feature which seems to choke on the multi-partition image. I can live
with uploading a 1.5GB raw image and then resizing the partition. :)

Noting that you also have a working demo of a single partition image
type, that we may see in the near future.

Thanks very much for your help!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]